Error | Protect Mode 4 on K.2 Series loudspeakers

Learn how to activate and use Protect Mode 4 to protect against errors and improve the status of your system.

Updated at August 8th, 2024

 

 

Message

THE MESSAGE:  “PROTECT MODE 4” | “POSSIBLE SPEAKER DAMAGE DETECTED.” | “NEXT”


Causes

The PROTECT MODE 4 message can appear during operation.  This indicates that the firmware has detected a potential issue.  If this occurs, audio will stop and the listed procedure will be needed to clear the message.  

If the message appears repeatedly during operation, the speaker will need to be sent to a QSC Authorized Service Center for evaluation. 


Definition

In general, PROTECT MODE 4 (PM4) is a protection within the firmware that is monitoring over-current incidences with the amplifier power supply and amplifier output section.  The protection message is mostly triggered when the speaker is driven beyond its engineered specifications.    If the DSP senses consecutive over-current incidents in quick succession, it will trigger the PM4 warning.  This could indicate damage to the voice coil of the LF driver.  If the voice coil is compromised, that can impact the driver’s impedance thereby causing the resistive value to increase.  As a result, the current on the output section can equally increase.  Once the current exceeds the threshold established in the DSP, the DSP will trigger the PM4 message and audio will stop.   If the warning is ignored and the speaker is consistently driven in to protection, this can lead to damage to the output section of the amplifier.  Again, this is intentional to help protect the amp output section and stop any damage to the voice coil. 

QSC has also recognized that there may be false triggers.  The false triggers can be initiated due to a deviation of component tolerances If the application is low to moderate SPL with very dynamic instrumentation.  If this is the case, it is recommended to  apply dynamic processing to the instrumentation with high transient peaks at the mix position.

If the application is moderate to high SPL from the speaker with more compressed dynamics and is not exceeding the specifications of the speaker, the issue does not occur.

Regarding firmware, the 1.3.3 / 1.4.1 and 1.5.5 firmware builds both have the same over-current protections.  The only difference is the MCU chipset which is the processor running the speaker.  Firmware 1.5.5 was released due to the implementation of the new chipset triggered by supply chain shortages of the original component.  The change in MCU and subsequent firmware has no impact on the PM4 warning messages.


 

Solution | Workaround

  1. Press “NEXT” to navigate to the next step.
  2. NEW MESSAGE = “PROTECT MODE 4” | “A 100HZ TONE WILL BE PLAYED” | “NEXT” 

  1. Press “NEXT” to engage the test tone.
  2. NEW MESSAGE = “IS TONE CLEAR AND UNDISTORTED?” | “YES” or “NO” 

  1. Listen and confirm if the tone is clear:

Click along the next steps based on your speaker's responses:

Press “Yes” if the audio is clear and sounds like a pure sine wave.

Press “No” if the audio has distortion or is NOT CLEAR.

Yes

 

No

 
 

The LCD will display a new message:    NEW MESSAGE = “PROTECT MODE 4” | “SPEAKER IS OKAY” | “EXIT”

Press Exit

 
 

Press “EXIT” and the speaker will go back to the “Home” screen and resume normal operation.

 
 

The LCD will display a new message:     NEW MESSAGE = “PROTECT MODE 4” | “PLEASE CONTACT A QSC SERVICE CENTER” 

Contact QSC Service Center

 
 

This indicates that there is already damage on the low frequency driver and that the speaker will need to be sent to a QSC Authorized Service Center for further inspection. You may also Click Here to create a case with QSC Support.

 
 

Note

If “NO” was pressed accidentally and the tone was in fact clear, power cycle the speaker and the PROTECT MODE 4 message will start over again. Proceed through the test again to confirm that the tone is clear.

 

In all instances should the error persist, there is a hardware issue occurring that will require repair with a QSC Authorized Service Center. It is recommended to stop using the speaker to avoid potential further damage.