Troubleshooting | CP loudspeaker is on, but there is no sound
Learn how to troubleshoot common issues with your CP loudspeaker when there is no sound coming out despite being turned on.
Affected Products
Hardware Model/Series | CP Series Loudspeakers |
Software | n/a |
Problem
The CP Series loudspeaker is powered on but there is no output.
Causes
No output from a speaker can be do to a number of possibilities, from a signal setting to a hardware issue.
Solution | Workaround
Use the suggestions below to verify possible issues in the signal chain:
- Check that all connections from the source audio to the speaker input are complete.
- Check that the source audio is turned up and not muted.
- Check the gain knob on the speaker that it is turned up.
- Try another audio cable to ensure the current one is not bad.
- Test the audio source in another known, working speaker.
If problems continue after testing, Create a Case or reach out to QSC Technical Support for further assistance, or reach out to an Authorized Service Center near you.